Application and interface

Wikis > Game engine manual > Application and interface

This page describes the Nebula level editor and related applications’ basic use and interface.

 

Overview

Nebula – for basic usage – consists of 4  related applications:

  • The Level Editor – where you create levels, place assets, lights and events. You can also launch the level active in the Level Editor in the Level Viewer to play it.
  • The Content Browser – where you manage your content library, edit settings for models, etc.
  • The Batch Exporter – which converts user-created data and content to file formats Nebula can read.
  • You can also launch the Level Viewer which launches whichever level has been set to the startup level in your game project, in the Level Editor.

The basic workflow is as follows:

  • Block in your level in the Level Editor using preset basic content (a “white-box” level) and scripting functionality.
  • Use a DCC (direct content creation) software to create the art assets to be used in the level. Save them as .fbx or texture files in your project.
  • Run the Batch Exporter to convert the files to Nebula-friendly formats.
  • Edit settings, such as assigning textures to models or identifying animation clips from a timeline, in the Content Browser. If necessary, you can re-import assets as well.
  • Populate your level in the Level Editor with your new content. Fine-tune lighting and post effects.
  • Play the level!

 

Level Editor

See the Level Editor Reference for the full documentation of the Level Editor.

LevelEditorExample01

The Level Editor is used to create levels for Nebula. Assets created with the Content Browser can be placed out, lights, level scripts, etc may be created, and the level can be launched for play testing.

Create Environment Entities to build a static level, and place Light Entities to light it. Add Game Entities – objects with some game functionality – to start building a game. Group and organize entities in the Scene List. Use the PostEffects Window for modifying the global appearance of your level. (You can also place out PostEffect Bubbles for localized changes.) From the menus, you can create new Game Entities through Blueprints, as well as Scripts. Place Game Entity trigger volumes to enhance your scripting capabilities!

When you are done, save your level. Under the Game menu, you can specify the active level to be the default, start-up level for the project. Test the gameplay by launching the game in the LevelViewer.

 

 

Content Browser

See the Content Browser reference for full documentation.

Roughness set to 1.0

The Content Browser is used by Nebula to edit assets such as models, textures, animations and so on. These assets can then be used in the Level Editor. It provides a list – the Content Library – of available content (files converted to Nebula formats under /projects/<your project>/export_win32/) such as Models and Textures. By selecting an item in the list, it is previewed in the viewport and you can edit its settings in the Asset settings to the right. You may also edit the way the model is displayed – such as the lighting and post effects – in the Post Effects Settings found in the Window menu.

You can also import individual items – .fbx and texture files – into the Content Library, and create Particles. Common tasks in the Content Browser include selecting which shader type a model should use, assigning textures to the material’s attributes, defining texture import settings (such as linearizing it or not, and which DXT compression to use), and – when importing several animations placed along a timeline – identifying and naming animation clips. Under the Tools menu, you can Connect with the Level Editor so that – when you hit Save – changes you’ve made instantly are updated in the Level Editor.

 

 

 

Batch exporter

See the Batch exporter reference for full documentation.

Nebula_BatchExporter

The Batch Exporter is used by Nebula to convert working files (which are easy for an user to create and edit) to Nebula files (which are easy and quick for Nebula to read and render). It looks for working files created under /projects/<your project>/work/ and converts them to a parallel file structure under /projects/<your project>/export_win32/. Working files which have not been exported cannot be read by Nebula  While you can use the Content Browser to import individual files, the Batch Exporter checks your entire working directory for changes and converts files for you.

Use the File menu to set Nebula project settings: this only needs to be done once for a project to be initialized.

Afterwards, you can selectively choose which content types you wish to export with the check boxes to the left. Optionally, you can increase the number of parallel jobs the exporter will run (depends on how many parallel threads your computer can run) and whether or not to Force a re-export of all content existing in the project directory. Leaving it off will only export new or changed files. Once the Exporter is done, you should be able to find all your updated content in the Content Browser and Level Editor.

 

Skip to toolbar